Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-100639

11.2-release UI inconsistent / broken behavior for 'Reporting->Memory' elements and graphs.

    XMLWordPrintable

Details

    Description

      While running OS: FreeNAS 11.2-release, discovered inconsistent and unexpected behavior of UI when reviewing reports and analytics for @ 'Reporting' -> 'Memory' element, while switching view options from 'grid' to a 'column' mode.

      At times graphs are not displayed at all, at other times graphs, more specifically - the with of the graphs are distorted.
      When graphs are missing all together, refreshing the page dose not resolve the issue.
      To bring graphs back, user has to chose a different element from the drop down menu like 'CPU', wait until CPU graph is loaded, and than chose the 'Memory' element from the drop down menu to access memory graphs once more.

      Client accessing the UI of the FreeNAS 11.2-release instance:

      OS: Debian 9 (Stretch) + Gnome Desktop
      Browser01: Mozilla Firefox Ver: 60.4.0esr (64-bit)
      Browser02: Chromium Version 71.0.3578.80
      Protocol: HTTP
      Issue(s) persist regarding of the brand/version of the browser(s) used.

      Please not that the general performance of the new UI in terms of the speed/responsiveness, relative to the legacy UI - sluggish, in some cases depending what parts/elements of the new UI accessed - almost unusable.

      Please see scree-shots attached:

      D. Myracle

      Attachments

        Attachments

          JEditor

            Issue Links

              Activity

                People

                  erin Erin Clark
                  skynas Damien Myracle
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                    Created:
                    Updated:
                    Resolved: