Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-105604

VMs stopping or displaying as stopped when they are not




      Apologies for the long winded description, but I don't know what the problem is, just some symptoms!  I'm running 4 Ubuntu Server 18.4 VMs on my FreeNAS box 24x7

      • 1CPUx1GB  for OnlyOffice Document Server
      • 1CPUx512MB for Pi-Hole
      • 1CPUx5GB for CrashPlan (also running a light graphical desktop)
      • 2CPUx8GB for Docker/Portainer running ~25 containers

      I have a few others that I spin up from time to time just for testing things, but very infrequently and I don't think I've even tested they still work since upgrading to 11.3

      This worked to a point on my old machine (X10 E3-1231v3 with 32GB) although some of the VMs were combined, but I built a new machine (X11 E3-1230v6 with 64GB) in December 2019 and created everything in it's own VM.

      It was working well for a couple of months running 11.2-U7 but has been a little problematic since upgrading to 11.3-U1.

      I woke this morning and the Crashplan VM was down (I have a VNC session to this open on my desktop so I notice if this is down).  I went to the FreeNAS WUI to restart, but the list of VMs show them all as down.  I checked Pi-hole, OnlyOffice and Portainer, and all the services are still running so the VMs must be.  I tried to restart the Crashplan VM from the switch on the VM page, but got an error message.  I opened the details and tried to Restart button, which worked and started the VM.  So now I have all 4 running, but the WUI is only showing Crashplan running which I restarted.  I've attached some screenshots to hopefully show this.

      Let me know if you need anything else.







                waqar Waqar Ahmed
                adrianwi Adrian Williamson
                0 Vote for this issue
                4 Start watching this issue