Uploaded image for project: 'FreeNAS / TrueNAS'
  1. FreeNAS / TrueNAS
  2. NAS-106239

IPv6 default gateway disappears

    XMLWordPrintable

    Details

      JEditor

        Description

        In FreeNAS itself (not the jails, not VMs), the default IPv6 gateway will disappear after boot (if it is set at all). Specifically, there is no "default" destination/entry running "netstat -6nr".

        Set up:

        • No default gateways set under Network > Global Configuration.
        • Under Network > Interfaces > primary interface, "DHCP" and "Autoconfigure IPv6" are checked.
        • All network interfaces have IPv6 addresses. rtsold appears to be running (checked with onestatus, since rtsold_enable is not YES).
        • Jails and VMs have proper IPv6 connectivity (e.g., "ping6 google.com" works), but FreeNAS itself does not.

        The default gateway stops disappearing if I add two tunables "ipv6_activate_all_interfaces" and "rtsold_enable" set to YES (per https://www.ixsystems.com/community/threads/11-3-ipv6-routing-problems.82045/). This is the same configuration I see added to /etc/rc.conf of jails.

          Attachments

            Attachments

              Activity

                People

                Assignee:
                themylogin Vladimir Vinogradenko
                Reporter:
                xviruz y
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Due:
                  Created:
                  Updated:
                  Resolved: