Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-106994

OpenVPN Service : Could not determine IPv4/IPv6 protocol

    XMLWordPrintable

    Details

    • Impact:
      Low

      Description

      I'm actually on the 12-BETA1

      Openvpn vpn service cannot determine if he need to listen UDP4 or UDP6

      Because on config we say only UDP, and i'm unlucky because he choose IPV6  automaticaly

      Wed Jul 29 20:15:12 2020 Diffie-Hellman initialized with 2048 bit key
      Wed Jul 29 20:15:12 2020 Failed to extract curve from certificate (UNDEF), using secp384r1 instead.
      Wed Jul 29 20:15:12 2020 ECDH curve secp384r1 added
      Wed Jul 29 20:15:12 2020 ROUTE_GATEWAY 10.10.0.1/255.255.255.0 IFACE=vmx0 HWADDR=xxxxxxxxxxxxxxxxx
      Wed Jul 29 20:15:12 2020 TUN/TAP device /dev/tun0 opened
      Wed Jul 29 20:15:12 2020 /sbin/ifconfig tun0 10.99.0.1 10.99.0.2 mtu 1500 netmask 255.255.255.255 up
      Wed Jul 29 20:15:12 2020 /sbin/route add -net 10.99.0.0 10.99.0.2 255.255.255.0
      add net 10.99.0.0: gateway 10.99.0.2
      Wed Jul 29 20:15:12 2020 Could not determine IPv4/IPv6 protocol. Using AF_INET6
      Wed Jul 29 20:15:12 2020 Socket Buffers: R=[42080->42080] S=[9216->9216]
      Wed Jul 29 20:15:12 2020 setsockopt(IPV6_V6ONLY=0)
      Wed Jul 29 20:15:12 2020 UDPv6 link local (bound): [AF_INET6][undef]:1194
      Wed Jul 29 20:15:12 2020 UDPv6 link remote: [AF_UNSPEC]

       

      I think it's because i got IPV6 and IPV4 on my nas

      nas# ifconfig
      vmx0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
              options=a400b9<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6>
              ether 00:0c:29:9e:03:fa
              inet6 fe80::20c:29ff:fe9e:3fa%vmx0 prefixlen 64 scopeid 0x1
              inet 10.10.0.245 netmask 0xffffff00 broadcast 10.10.0.255
              media: Ethernet autoselect
              status: active
              nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
      
      

       

      workaround set proto to UDP4 TCP4 UDP6 TCP6 

       

       

       

        Attachments

          Attachments

            JEditor

              Activity

                People

                Assignee:
                waqar Waqar Ahmed
                Reporter:
                Ekozan Maxime FRANCK
                Watchers:
                Bug Clerk, Maxime FRANCK, William Grzybowski
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: