Uploaded image for project: 'FreeNAS / TrueNAS'
  1. FreeNAS / TrueNAS
  2. NAS-107322

qcow2 image corruption and I/O issues with NFS4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Engineering Closed (View Workflow)
    • Priority: Low
    • Resolution: Duplicate
    • Affects Version/s: 12.0-BETA2
    • Fix Version/s: N/A
    • Component/s: OS

      Description

      We've encountered an issue with TrueNAS 12 BETA-1 and BETA-2 and NFS 4.1 mounted QCOW2 images for virtual machines:

      After running perfectly for several days, some of the VM qcow2 images start randomly showing scsi I/O errors on VM level - sometimes easily recoverable, sometimes corrupting contained VM ext4 filesystem or sometimes the corrupting the qcow2 image file.

      TrueNAS server does not report any storage issues when these occur. Rolling back to 11.3-U4.1 seems to prevent the corruptions from happening. These same virtualization systems have been running with FreeNAS NFS4 backed storage for years without any storage issues.

      We've observed this behaviour in two physically separate Proxmox VM 6.2 clusters backed by TrueNAS 12 BETA installations with slightly different hardware. We believe this behaviour is not limited to single server or VM host cluster.

      Related discussion: https://www.ixsystems.com/community/threads/issues-with-qcow2-images-and-truenas-core-12-0-beta.86710/

        Attachments

          Attachments

            JEditor

              Issue Links

                Activity

                  People

                  Assignee:
                  releng Release Council
                  Reporter:
                  nodefield Ilkka Myller
                  Votes:
                  2 Vote for this issue
                  Watchers:
                  9 Start watching this issue

                    Dates

                    Created:
                    Updated:
                    Resolved: