Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-109045

CallError - [EFAULT] Failed to set NT password for XXXXXX: Username not found!

    XMLWordPrintable

    Details

    • Impact:
      High

      Description

       

      Okay, so I have created my groups with my validated permissions and now am half way through my list of 45+ users. Very simply, all I am entering is their full name, truncated username, support email, and adding their corresponding group to the primary group selection. Now as I am halfway through entering the users I can no longer add any more. It gives this error error after submitting, so I press back look at the list and see the user still listed their. Thinking on my feet, I try deleting the user record, then re-adding, still the same thing. So maybe I got to trick it by deleting that record and trying to add a different truncated name, go back in and edit it to the correct name. Nope, same error message. It's literally.... driving.... me .....batty especially when I'm at a stand still on this. Is this a known issue of sorts that I am unaware of? Also there are no special characters being used. 

       

      [EFAULT] Failed to set NT password for mrsamerica: Username not found!
      Error: Traceback (most recent call last):
      File "/usr/local/lib/python3.8/site-packages/middlewared/main.py", line 137, in call_method
      result = await self.middleware._call(message['method'], serviceobj, methodobj, params, app=self,
      File "/usr/local/lib/python3.8/site-packages/middlewared/main.py", line 1195, in _call
      return await methodobj(*prepared_call.args)
      File "/usr/local/lib/python3.8/site-packages/middlewared/service.py", line 455, in create
      rv = await self.middleware._call(
      File "/usr/local/lib/python3.8/site-packages/middlewared/main.py", line 1195, in _call
      return await methodobj(*prepared_call.args)
      File "/usr/local/lib/python3.8/site-packages/middlewared/schema.py", line 973, in nf
      return await f(*args, **kwargs)
      File "/usr/local/lib/python3.8/site-packages/middlewared/plugins/account.py", line 316, in do_create
      await self.__set_smbpasswd(data['username'])
      File "/usr/local/lib/python3.8/site-packages/middlewared/plugins/account.py", line 857, in __set_smbpasswd
      await self.middleware.call('smb.update_passdb_user', username)
      File "/usr/local/lib/python3.8/site-packages/middlewared/main.py", line 1238, in call
      return await self._call(
      File "/usr/local/lib/python3.8/site-packages/middlewared/main.py", line 1195, in _call
      return await methodobj(*prepared_call.args)

       

        Attachments

          Attachments

            JEditor

              Activity

                People

                Assignee:
                awalker Andrew Walker
                Reporter:
                Garcia Justin
                Watchers:
                Andrew Walker, Bug Clerk, Justin, Noor Amli, William Grzybowski
                Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: