Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-109273

SMB share is unavailable because it uses a locked dataset




      I have 2x mirrored USB drives for boot, 2x mirrored SSDs for SLOG, and 5x HDDs in Z2 configuration for my one data pool. The pool is encrypted with an automatic key, which I don’t have since I recently finished my build and hadn’t backed the key up yet.

      When physically replacing the computer system fan, I had unplugged the 1x of the USB drives, both SLOG SSDs, and 1x of the HDDs that is part of the pool and forgot to plug them back in before I powered the system on. The system went through the full boot process.

      I have since re-connected all devices and rebooted the system, but all of the datasets in the pool now have this alert “SMB share (fill in dataset name) is unavailable because it uses a locked dataset.”

      Before my mistake, the encryption key would be re-loaded on every reboot to unlock the pool, but through all of my research thus far, I have not been able to figure out the correct way to get the system functioning normally again.

      Since this incident, I downloaded a copy of the config with the secret seed and the encryption key, and I have looked through the file to find the correct string to manually copy/paste into the unlock pool menu, but one of the 64bit strings I have tried so far have worked. Even though I clicked the checkbox to include the encryption key, I am wondering if the encryption key is actually included in the config export since the pool is locked.

      I have considered, but not yet tried rebooting with each of the USB boot drives individually to see if one of them will return the system to a normal functioning state.

      From a bug perspective, shouldn’t there be tolerance built in to be able to recover from this type of event automatically without a large intervention?






                waqar Waqar Ahmed
                robertbarry79 Robert Barry
                0 Vote for this issue
                4 Start watching this issue