Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-109404

Slow SMB read speed after 12.0-U2 update - still the same problem

    XMLWordPrintable

    Details

      Description

      Hi.

      There is still a problem with the SMB read speeds on chelsio and intel nic.

      My system 1

      Ryzen 3 2200G ,32GB non ecc 8x Seagate Baracuda 2Tb drives + 120 GB SSD for testing.

      Onboard nic + Chelsio N320E T320

      My System 2

      Intel I5-3550 32Gb Non ecc 8x Toshiba p300 2TB drives + 120 GB SSD for testing

      Both Systems pools are configured into raid Z1. 1 backup and other 7 for storage.

      The system performance is stable without any problems in TrueNas 12.0-U2 And Freenas 11.0-U5.

      On Freenas version 11.3-u5 the smb write and read speeds where arround 425 to  500 MB/s on my mechanical drives Z1 pool. SSD test drive was 500 Mb/s Read and write.

      After update to True nas the write speed is a bit lover 426 Mb/s for a 20 gig file and thats fine but the read speed is horrible 86 Mb/s from Z1 mechanical drives and the SSD drive.

      The following test i performed was i just reverted to from Truenas 12 to Freenas 11.3 but the speed off the Z1 pool was to my supprise still low 86 MB/s.

      I swaped my celsio nic for an intel x520 DA1 10 gig nic and the problem was still the same .

      Then i decided to do a brand new instaal of freenas 11.3 i had the iso downloaded and tested it with the chelsio and intel nics on a SSD drive for read and write speeds and it was the same 82 MB/s Read 455 write.

      So i used another Chelsio nic on my amd system that was used in my linux server for office.

      And i have noticed when i plugged it in and the Truenass was booting on the post that it gave me a message WRITING NEW NIC FIRMWIRE. It took arround 20 seconds and it just continued to boot normaly. But the same SMB read problem is still here.  This chelsio nic was never used in Freenas  N320E T320

       

      Now the Chelsio NIC card is having problems in the linux server a bit slower transfer speeds and random package drop outs. intel x520 DA1 Nic is working fine in the linux server.

       

      I thing there is a problem with the chelsio and intel Nic drivers in TrueNas.

      Is there a cosole command to force or manual install older Nic Drivers that where working in FreeNAs 11.3-U5 ?

      Thanks

       

       

        Attachments

          Attachments

            JEditor

              Activity

                People

                Assignee:
                releng Triage Team
                Reporter:
                Grohotnius Eddie Hall
                Watchers:
                Bonnie Follweiler, Eddie Hall, Joe Maloney
                Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: