Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-110105

Removed drive degrades pool - but insertion does not change pool status

    XMLWordPrintable

    Details

    • Type: Defect
    • Status: Engineering Closed (View Workflow)
    • Priority: Low
    • Resolution: Duplicate
    • Affects Version/s: SCALE-21.04-ALPHA.1 (Angelfish)
    • Fix Version/s: N/A
    • Component/s: None
    • Labels:
      None

      Description

      TrueNAS-SCALE-21.04-MASTER-20210408-072923

      FN01

      I mistakingly pulled a drive for a pool, pool showed degraded.  I reinserted drive, pool never shows as healthy.  Also, found the correct drive to pull (for another pool), pulled that drive, but that pool never shows as degraded.  One pool it works on, the other it doesn't.  Situation was resolved once I rebooted the system.  Healthy drive showed healthy, degraded pool showed degraded.  

      Also, for the second drive I pulled, a spare was attached to that pool.  Spare never integrated into the pool.  Screenshot provided.

        Attachments

          Attachments

            JEditor

              Activity

                People

                Assignee:
                releng Triage Team
                Reporter:
                jervin Jeff Ervin
                Watchers:
                Jeff Ervin, William Grzybowski
                Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: