Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-110166

Winbind does not start on boot

    XMLWordPrintable

    Details

    • Impact:
      Low

      Description

      I'm running TrueNAS-SCALE-21.04-MASTER-20210401-192917 and Active Directory binding does not work on boot.  Going to the active directory config and just hitting save fixed it.  I've also discovered that doing a midclt call service.restart cifs fixes the problem.  It appears that on boot winbind is not started, but on restart it is.  Here is the bootup and restart entries from syslog.

      Boot
      Apr 12 20:30:19 truenas systemd[1]: Starting Samba SMB Daemon...
      Apr 12 20:30:20 truenas systemd[1]: Started Samba SMB Daemon.
      Missing winbind startup entries

       

      Restart
      Apr 12 20:35:19 truenas systemd[1]: Stopping Samba SMB Daemon...
      Apr 12 20:35:19 truenas systemd[1]: Stopped Samba SMB Daemon.
      Apr 12 20:35:20 truenas systemd[1]: Starting Samba SMB Daemon...
      Apr 12 20:35:20 truenas systemd[1]: Started Samba SMB Daemon.
      Apr 12 20:35:20 truenas systemd[1]: Starting Samba Winbind Daemon...
      Apr 12 20:35:20 truenas systemd[1]: Started Samba Winbind Daemon.

        Attachments

          Attachments

            JEditor

              Activity

                People

                Assignee:
                awalker Andrew Walker
                Reporter:
                magic280z Sam Beckler
                Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved: