Uploaded image for project: 'TrueNAS'
  1. TrueNAS
  2. NAS-105802

CA import broken in 11.3U1/U2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Medium
    • Resolution: Complete
    • Affects Version/s: 11.3-U2, 11.3-U1
    • Fix Version/s: 12.0-ALPHA2, 11.3-U3
    • Component/s: WebUI
    • Labels:
      None

      Description

      I have 2 instances of FreeNAS both now updated to 11.3U2. This problem seemed to have started in 11.3U1. I had previously configured AD integration using encrypted method. I imported the root CA exported from my domain controller's certificate authority. The AD functionality was working up until 11.3U1. In attempt to troubleshoot the issue, I tried upgrading to 11.3U2 and it still yielded the same error. The CA cert my AD configuration was using appeared in both CA and Certificates sections. However, the item in Certificates section shows up with a "migrated" label.

      Under Certifcates

      Under CA

       

      However, when I try to re-configure AD, it complains about not being able to find the certificate. I then changed the certificate AD config was using to something else temporarily, then deleted the cert under both CA and Certificates sections and re-imported it back into CA. I then try to re-configure AD settings one more time, and now it's saying it can't even find the cert with the id.

        Attachments

          Attachments

            JEditor

              Issue Links

                Activity

                  People

                  Assignee:
                  dmullen Dennis Mullen
                  Reporter:
                  eroji Jimmy Chen
                  Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                    Dates

                    Due:
                    Created:
                    Updated:
                    Resolved: